64位linux里安装cisco anyconnect vpnclient

Life is short , play more!
本文来自lihao's Blog,转载请注明。

cisco anyconnect vpn client 只有32位的linux版本.所以使用64位linux系统的同学们,只有装一大堆cisco anyconnect vpn 所需要的i386 或者 i686 的库了.  另外, 安装成功以后, 会发现, 一直提示certification failed 的错误. 证书验证无法通过.

是因为证书的问题.  需要服务端更换证书. 如果不希望购买证书.

1.  我们需要允许该证书.  目前尝试可以的办法是,  卸载firefox x64 位, 务必要安装firefox  i368 或者 i686 (32位的即可) . 运行firefox ,  打开你要vpn server的host地址.

2. 访问后, firefox 提示你的证书不可信, 所以我们需要添加到例外里.

3. 此时,我们再次用cisco anyconnect vpn client 去连接, 这时候,就会提示你输入用户名密码了.

[[email protected] profile]# ../bin/vpnCisco

AnyConnect VPN Client (version 2.4.0202) .
Copyright (c) 2004 – 2009 Cisco Systems, Inc.All Rights Reserved.

>> state: Connected

>> registered with local VPN subsystem.

>> state: ConnectedVPN> state

>> state: ConnectedVPN>


发表评论

电子邮件地址不会被公开。 必填项已用*标注