如何更新php版本

Life is short , play more!
本文来自lihao's Blog,转载请注明。

[[email protected] modules]# cat /etc/redhat-release
CentOS release 6.6 (Final)

通过yum安装的php 仅是5.3.3 版本, 太老,最新的已是5.6x , 所以决定更新一下。 (因为用plates templage engine , 一些高级php特性,5.3.3 支持的不够好)

下面就开始升级吧。

1.  yum groupremove php && yum remove php-common

移除所有的php rpm包,我们要 手动用源码安装

2.  wget 下载

wget -O php-5.6.10.tar.bz2 “http://cn2.php.net/get/php-5.6.10.tar.bz2/from/this/mirror”

3. tar -jxvf 解压之

4. ./configure –with-apxs2=<path to apxs >  –with-mysql

这里要说明, apxs 找不到不要怕, 你需要安装 yum install httpd-devel , httpd 开发包里包含了这个命令哦。 是 apache extension tools , 这里我们通过 –with-apxs2=<path to apxs >,  则会编译 apache2 (httpd) 的 php handler so 模块module.

5.  make && make install

6.  编译,安装成功后,那么我们就看到了 libphp5.so 这个针对与apache httpd的模块了。 会默认帮你拷贝到 对应的 httpd/modules/ 里。  httpd 为你apache httpd的安装目录。

7.  根据http://php.net/manual/en/install.unix.apache2.php

文档, 在 conf.d/ (httpd 的配置文件里) 可以创建一个 php.conf 包含如下内容

LoadModule php5_module modules/libphp5.so
<FilesMatch \.php$>
SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch “\.phps$”>
SetHandler application/x-httpd-php-source
</FilesMatch>

重启 httpd , 好了, php5 升级成功了。  重启前,别忘了拷贝一份 php.ini 哦。  这个是php的配置文件按。

 

 


发表评论

电子邮件地址不会被公开。 必填项已用*标注